twitter_oauthがインストールできない

表題どおりです。
TwitterAPIが1.1になったおかげでうちのbotが動かなくなりまして(1.1ってOauth対応のことだと勘違いしてたからものすごい油断してた)、慌てまして。とりあえずライブラリを更新して動かして動かないところを書き換えようと。
と思っていたのですが、なんとtwitter_oauthが更新できない問題が。

%gem update twitter_oauth

と入力してみると、なんかエラーメッセージと同時にtwitter_oauthの代わりにoauthを更新するという動きをしまして。

なんだこれと思って、twitter_oauth自体の更新状況を調べに行ってみたわけです。
GitHub - moomerman/twitter_oauth: 🚫 DEPRECATED - Use https://github.com/sferik/twitter
ざっくりですが、ここ3〜1日以内に何かしら更新があって、twitterAPI1.1対応したことは間違いないらしいです。
が、アップデート出来ない。

で、短気にもアンインストールして再インストールを試みました。
ら、

ERROR: Failed to build gem native extension.

というエラーメッセージが。もうどうなってるんだか。

と思ってましたが

さっきのGitHub - moomerman/twitter_oauth: 🚫 DEPRECATED - Use https://github.com/sferik/twitterにヒントがありそうです。
英語に挫折間近ですが頑張ってみよう。

関数をオブジェクトとして捉える

こんばんは。予定の日数をはるかに過ぎて未だに基礎的な勉強を続けております。
てわけでここしばらくで思い切り引っかかってたのが上の件。
以下、何に引っかかっていてどう理解に至ったのかという話。……たぶん。

続きを読む

Famous Writer

先日オンセのチャットで『はーとふる彼氏』が話題になった関係で、なんでか「Famous Writer」というノベルゲーツールをいじり始めました。
まだ1日2日なので大したことはわかってないしこのまま1本ゲームを作り終えるまでやるかというと大変微妙(自分の飽きっぽさ的な意味で)なのですが、せっかく気づいた点があるので以下おぼえ書き。

なお、使用しているのはVer3です。

続きを読む

応援バナーのランダム表示

個人的にはまってる某乙女ゲーのファンディスクが出るということで、その応援バナー18種をランダム表示したくなりました。
が、公式では用意されてませんでした。
ので久々にJavaScriptをいじることにしました。
といっても作りは単純です。
元々の応援バナーへのurlのかなりの部分が共通なので、

  1. 共通部分をすべて定数定義constにつっこみ、
  2. 違う部分だけ配列に突っ込んでランダム出力

だけです。
スクリプトを書くにあたっては
http://javascript.eweb-design.com/0804_ri.html
↑を参考にさせていただきました。

続きを読む

エクスプローラーのフォルダのコンテキストメニューに「コマンドプロンプトで開く」を追加する。

フォルダアイコンの上で右クリックした時のメニューに「コマンドプロンプトで開く」を追加するということです。PCでRubyいじるのにあるととっても便利なので。
改めて教えてもらったので忘れないうちにメモ。なお対象はWindowsXPVistaとかは違うかも。
参考にされる方は自己責任で。

続きを読む